Remote message window on same computer not connecting

Started by IceBotYT, February 29, 2024, 10:09:08 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I had the same issue, but found that I needed a physical cable connection instead of WiFi (to the same network) before local machine operation would work.

@David, can you add LocalHost ( to the list of available options?


Quote from: IanH on March 05, 2024, 06:12:55 AM@David, can you add LocalHost ( to the list of available options?

I second this! This would help a lot


Odd.  It works fine on my laptop with wifi only.  In testing I have found the following:
The wifi adapter must be "connected" with an IP address (not 169.254... auto private ip) before msgWindow and MP are started.

The adapter setting in msgWindow does not need to be set for it to work.  If I start msgWindow before MP, it waits with "Connecting..." until MP starts.

In MP Production>Messages, I don't need to setup a network patch.  All that is needed is selecting the wifi adapter in the list at the bottom of the panel.  As soon as I select it, the msgWindow displays connected and then blank waiting for a message.

msgWindow apparently does not rescan for network adapters once it is configured to use a specific adapter in settings (should have someone else verify).  I have to delete the adapter entry in the preferences file in order for it to list new/changed network adapters while viewing settings window.

Windows 11 should have prompted you with security warning (Unknown publisher that is not trusted and also for network access to any private and public networks) the very first time you ran MultiPlay to allow it to run.  Was the feature to check for unknown publishers disabled on the machine?


The download post for MultiPlay has been updated with the link for version of MsgWindow.

I've added Local Host to Settings > Adapter which will direct it's connection requests to so hopefully that's one piece of the puzzle sorted.


I have downloaded the latest version of Multiplay ( and MsgWindow ( and I am also having no luck with connecting them both. (created a message patch in MP with a message cue)

I have left everything on default and used Local Host on both MP and MsgWindow (running on same PC) and it still displays "Waiting to connect...".

I attempted this on Windows 10 and 11, and have even tried to use the two PCs over the network by changing the adapter, however still no luck.

I have tried the methods in the posts above, but I am yet to get it working.
Any ideas to try and get this up and running would be great.

Thanks in advance!


For the Production Properties > Messaging > Adapter setting, don't use Local Host for now. Use the specific (real) adapter instead.